deliveroo.co.uk 65 packages

Last scanned on Jan 19 at 08:24 AM
url-parse 1.5.3VulnerableOutdated
Small footprint URL parser that works seamlessly across Node.js and browser environments
License
MIT
Footprint
4 KB
Vulnerabilities
url-parse incorrectly parses hostname / protocol due to unstripped leading control characters.
Affected versions >=0 <1.5.9
Authorization bypass in url-parse
Affected versions >=0 <1.5.6
Authorization Bypass Through User-Controlled Key in url-parse
Affected versions >=0 <1.5.8
url-parse Incorrectly parses URLs that include an '@'
Affected versions >=0 <1.5.7
Matched Modules
Version distribution in production
206
1.5.10
167
1.5.9
50
1.5.3
47
1.4.6
47
1.4.7
24
1.5.4
lodash 4.17.16VulnerableOutdated
Lodash modular utilities.
moment 2.19.0 - 2.25.1VulnerableOutdated
Parse, validate, manipulate, and display dates
video.js 5.14.0VulnerableOutdated
An HTML5 video player that supports HLS and DASH with a common API and skin.
es5-ext 0.10.1 - 0.10.62VulnerableOutdated
ECMAScript extensions and shims
next 12.3.0 - 12.3.4VulnerableOutdated
The React Framework
rauchg
timneutkens
vercel-release-bot
tslib 1.2.0 - 2.4.1Outdated
Runtime library for TypeScript helper functions
isarray 1.0.0 - 2.0.5
Array#isArray for older browsers
react-is 16.3.0 - 16.13.1Outdated
Brand checking of React Elements.
camelcase 5.3.1Outdated
Convert a dash/dot/underscore/space separated string to camelCase or PascalCase: `foo-bar` → `fooBar`
inherits 2.0.3Outdated
Browser-friendly inheritance fully compatible with standard node.js inherits()
buffer 4.6.0 - 4.9.2Outdated
Node.js Buffer API, for the browser
@babel/runtime 7.14.0 - 7.16.3Outdated
babel's modular runtime helpers
+1
hzoo
existentialism
nicolo-ribaudo
base64-js 1.3.0 - 1.5.1
Base64 encoding/decoding in pure JS
events 3.0.0 - 3.3.0
Node's event emitter for all engines.
retry 0.13.1
Abstraction for exponential and custom retry strategies for failed operations.
tim-kos
tim-kos
util 0.10.0 - 0.12.5
Node.js's util module for all engines
requires-port 1.0.0
Check if a protocol requires a certain port number to be added to an URL.
scheduler 0.15.0 - 0.23.0
Cooperative scheduler for the browser environment.
prop-types 15.8.0 - 15.8.1
Runtime type checking for React props and similar objects.
react 17.0.0 - 18.2.0
React is a JavaScript library for building user interfaces.
querystringify 2.2.0
Querystringify - Small, simple but powerful query string parser.
hoist-non-react-statics 3.3.1 - 3.3.2
Copies non-react specific statics from a child component to a parent component
mridgway
mridgway
querystring 0.2.0Outdated
Node's querystring module for all engines.
classnames 2.3.0 - 2.3.2Outdated
A simple utility for conditionally joining classNames together
query-string 4.3.0 - 7.1.3Outdated
Parse and stringify URL query strings
react-transition-group 4.1.0 - 4.4.5
A react component toolset for managing animations
@sentry/utils 7.0.0 - 7.31.1Outdated
Utilities for all Sentry JavaScript SDKs
+8
benvinegar
billyvg
mitsuhiko
@emotion/sheet 0.9.1 - 0.9.4Outdated
emotion's stylesheet
+1
emmatown
tkh44
emotion-release-bot
@sentry/core 4.2.2 - 7.31.1Outdated
Base implementation for all Sentry JavaScript SDKs
+8
benvinegar
billyvg
mitsuhiko
lodash-es 4.17.21
Lodash exported as ES modules.
redux 4.1.0 - 4.2.0Outdated
Predictable state container for JavaScript apps
babel-runtime 5.0.13 - 6.0.14Outdated
babel selfContained runtime
hzoo
loganfsmyth
existentialism
reselect 4.1.1 - 4.1.7Outdated
Selectors for Redux.
react-redux 7.1.0 - 8.0.5Outdated
Official React bindings for Redux
polished 1.0.0 - 4.2.2Outdated
A lightweight toolset for writing styles in Javascript.
async-retry 1.3.3
Retrying made simple, easy and async
+3
gdborton
matheuss
matt.straka
react-lifecycles-compat 3.0.4
Backwards compatibility polyfill for React class components
fb
sophiebits
split-on-first 1.0.0 - 2.0.0Outdated
Split a string on the first occurance of a given separator
p-is-promise 3.0.0 - 4.0.0
Check if something is a promise
@sentry/browser 5.0.5 - 6.19.7Outdated
Official Sentry SDK for browsers
+8
benvinegar
billyvg
mitsuhiko
copy-to-clipboard 3.3.0 - 3.3.1Outdated
Copy stuff into clipboard using JS with fallbacks
react-select 4.1.0 - 5.5.4Outdated
A Select control built with and for ReactJS
toggle-selection 1.0.5 - 1.0.6
Toggle current selected content in browser
framer-motion 6.5.0 - 8.5.0Outdated
A simple and powerful JavaScript animation library
@angular/router 10.0.0 - 14.1.3Outdated
Angular - the routing library
jss 3.4.0 - 3.5.0Outdated
A lib for generating Style Sheets with JavaScript.
@emotion/core 10.0.17 - 10.3.1Outdated
+1
emmatown
tkh44
emotion-release-bot
fp-ts 1.18.2 - 2.9.5Outdated
Functional programming in TypeScript
react-draggable 4.4.1 - 4.4.5Outdated
React draggable component
create-react-class 15.7.0
Legacy API for creating React components.
react-beautiful-dnd 1.0.0 - 6.0.2Outdated
Beautiful and accessible drag and drop for lists with React
react-use 16.1.0 - 17.3.1Outdated
Collection of React Hooks
streamich
streamich
react-modal 3.14.1 - 3.16.1
Accessible modal dialog component for React.JS
antd 4.4.2 - 5.1.5Outdated
An enterprise-class UI design language and React components implementation
redux-devtools-extension 2.0.0 - 2.13.9
Wrappers for Redux DevTools Extension.
+1
jhen0409
methuselah96
timdorr
@auth0/auth0-spa-js 2.0.0 - 2.0.2Outdated
Auth0 SDK for Single Page Applications using Authorization Code Grant Flow with PKCE
amplitude-js 5.2.0Outdated
Javascript library for Amplitude Analytics
react-truncate 2.3.0 - 2.4.0
React component for truncating multi-line spans and adding an ellipsis
aphrodite 0.6.0 - 1.2.0Outdated
Framework-agnostic CSS-in-JS with support for server-side rendering, browser prefixing, and minimum CSS generation
tesseract.js 2.0.0 - 4.0.2Outdated
Pure Javascript Multilingual OCR
+1
antimatter15
jeromewu
bijection
browser-cookies 1.2.0
Tiny cookies library for the browser
react-cookie-consent 8.0.0 - 8.0.1Outdated
A small, simple and customizable cookie consent bar for use in React applications.
tti-polyfill 0.2.2
Polyfill for Time to Interactive. See https://goo.gl/OSmrPk
philipwalton
philipwalton
react-amphtml 3.1.0 - 4.0.2
Use amphtml components inside your React apps easily!
dfrankland
dfrankland