escholarship.org 65 packages

Last scanned on Oct 27 at 06:11 PM
isarray 0.0.0 - 0.0.1Outdated
Array#isArray for older browsers
License
MIT
Footprint
159 B
Matched Modules
Version distribution in production
350
1.0.0
350
2.0.0
350
2.0.1
350
2.0.2
350
2.0.3
280
0.0.1
react-is 16.13.1Outdated
Brand checking of React Elements.
lodash 4.17.21
Lodash modular utilities.
@babel/runtime 7.18.2 - 7.18.3Outdated
babel's modular runtime helpers
+1
hzoo
existentialism
nicolo-ribaudo
path-to-regexp 1.8.0Outdated
Express style path to RegExp utility
es-abstract 1.19.3 - 1.20.1Outdated
ECMAScript spec abstract operations.
has-symbols 1.0.2 - 1.0.3
Determine if the JS environment has Symbol support. Supports spec, or shams.
get-intrinsic 1.1.3
Get and robustly cache all JS language-level intrinsics at first require time
has 1.0.2 - 1.0.3
Object.prototype.hasOwnProperty.call shortcut
tarruda
ljharb
define-properties 1.1.4
Define multiple non-enumerable properties at once. Uses `Object.defineProperty` when available; falls back to standard assignment in older engines.
function-bind 1.1.1
Implementation of Function.prototype.bind
is-callable 1.2.6Outdated
Is this JS value callable? Works with Functions and GeneratorFunctions, despite ES6 @@toStringTag.
object-assign 4.1.1
ES2015 `Object.assign()` ponyfill
object-keys 1.1.1
An Object.keys replacement, in case Object.keys is not available. From https://github.com/es-shims/es5-shim
call-bind 1.0.2
Robustly `.call.bind()` a function
is-date-object 1.0.5
Is this value a JS Date object? This module works cross-realm/iframe, and despite ES6 @@toStringTag.
is-symbol 1.0.2 - 1.0.4
Determine if a value is an ES6 Symbol or not.
is-string 1.0.7
Is this value a JS String object or primitive? This module works cross-realm/iframe, and despite ES6 @@toStringTag.
es-to-primitive 1.2.1
ECMAScript “ToPrimitive” algorithm. Provides ES5 and ES2015 versions.
has-tostringtag 1.0.0
Determine if the JS environment has `Symbol.toStringTag` support. Supports spec, or shams.
decode-uri-component 0.2.0
A better decodeURIComponent
array-includes 3.1.5
An ES7/ES2016 spec-compliant `Array.prototype.includes` shim/polyfill/replacement that works as far down as ES3.
prop-types 15.8.1
Runtime type checking for React props and similar objects.
has-property-descriptors 1.0.0
Does the environment have full property descriptor support? Handles IE 8's broken defineProperty/gOPD.
scheduler 0.19.1Outdated
Cooperative scheduler for the browser environment.
react 16.14.0Outdated
React is a JavaScript library for building user interfaces.
react-dom 16.14.0Outdated
React package for working with the DOM.
query-string 5.1.1Outdated
Parse and stringify URL query strings
hoist-non-react-statics 2.5.1 - 2.5.5Outdated
Copies non-react specific statics from a child component to a parent component
mridgway
mridgway
strict-uri-encode 1.1.0Outdated
A stricter URI encode adhering to RFC 3986
invariant 2.2.3 - 2.2.4
invariant
es5-ext 0.10.24 - 0.10.49Outdated
ECMAScript extensions and shims
history 4.10.1Outdated
Manage session history with JavaScript
warning 4.0.3
A mirror of Facebook's Warning
react-router 4.3.0 - 4.3.1Outdated
Declarative routing for React
react-router-dom 4.3.0 - 4.3.1Outdated
Declarative routing for React web applications
tiny-warning 1.0.2 - 1.0.3
A tiny warning function
alexreardon
alexreardon
tiny-invariant 1.2.0Outdated
A tiny invariant function
react-lifecycles-compat 3.0.4
Backwards compatibility polyfill for React class components
+2
gaearon
acdlite
fb
jquery 3.0.0 - 3.6.1
JavaScript library for DOM operations
resolve-pathname 3.0.0
Resolve URL pathnames using JavaScript
mjackson
mjackson
value-equal 1.0.1
Are these two JavaScript values equal?
mjackson
mjackson
exenv 1.2.1 - 1.2.2
React's ExecutionEnvironment module extracted for use in other packages & components
react-modal 3.15.1Outdated
Accessible modal dialog component for React.JS
intersection-observer 0.4.3Outdated
A polyfill for IntersectionObserver
smoothscroll-polyfill 0.4.4
Smooth Scroll behavior polyfill
react-ga 2.7.0Outdated
React Google Analytics Module
@chakra-ui/theme 2.1.0 - 2.1.3Outdated
The default theme for chakra components
ev-emitter 1.1.1Outdated
lil' event emitter
get-size 2.0.3Outdated
measures element size
desandro
desandro
fizzy-ui-utils 2.0.7Outdated
UI utilities
desandro-matches-selector 2.0.2
matches/matchesSelector helper
imagesloaded 4.1.4Outdated
JavaScript is all like _You images done yet or what?_
loadjs 4.2.0
Tiny async loader for modern browsers
flickity 2.3.0Outdated
Touch, responsive, flickable carousels
unidragger 2.4.0Outdated
Base draggable class
unipointer 2.4.0
Do one thing with one pointer
lozad 1.16.0
A light-weight JS library to lazy load any HTML element such as images, ads, videos etc.
react-meta-tags 0.7.4 - 1.0.0Outdated
Handle document meta/head tags in isomorphic react with ease.
flickity-imagesloaded 2.0.0
Enable imagesLoaded option for Flickity
better-react-mathjax x.x.x
details-polyfill x.x.x
get-form-data x.x.x
jquery.dotdotdot x.x.x
react-twitter-widgets x.x.x