rac.co.uk 4 packages

Last scanned on Oct 27 at 06:44 PM
ua-parser-js 0.7.20VulnerableOutdated
Detect Browser, Engine, OS, CPU, and Device type/model from User-Agent & Client Hints data. Supports browser & node.js environment
License
AGPL-3.0-or-later
Footprint
14 KB
Vulnerabilities
Regular Expression Denial of Service in ua-parser-js
Affected versions >=0 <0.7.22
Regular Expression Denial of Service (ReDoS) in ua-parser-js
Affected versions >=0.7.14 <0.7.24
ua-parser-js Regular Expression Denial of Service vulnerability
Affected versions >=0 <0.7.23
Matched Modules
Version distribution in production
414
0.7.24
152
0.7.28
100
0.7.31
89
1.0.2
50
0.7.32
25
0.7.20
uuid 7.0.0 - 8.0.0Outdated
RFC4122 (v1, v4, and v5) UUIDs
crypto-browserify 1.0.9 - 2.0.0Outdated
implementation of crypto for the browser
+2
dcousens
ljharb
cwmma
web-vitals 3.0.0 - 3.0.4Outdated
Easily measure performance metrics in JavaScript