thepaper.cn 59 packages

Last scanned on Oct 27 at 06:08 PM
lodash 4.17.16VulnerableOutdated
Lodash modular utilities.
License
MIT
Footprint
3 KB
Vulnerabilities
Regular Expression Denial of Service (ReDoS) in lodash
Affected versions >=0 <4.17.21
Prototype Pollution in lodash
Affected versions >=0 <4.17.20
Command Injection in lodash
Affected versions >=0 <4.17.21
Matched Modules
Version distribution in production
3 846
4.17.16
946
4.17.21
337
4.17.20
322
4.17.15
302
4.17.19
301
4.17.13
qs 6.11.0
A querystring parser that supports nesting and arrays, with a depth limit
react-is 16.3.0 - 16.13.1Outdated
Brand checking of React Elements.
@babel/runtime 7.18.0 - 7.19.4Outdated
babel's modular runtime helpers
+1
hzoo
existentialism
nicolo-ribaudo
fast-deep-equal 3.0.0 - 3.1.3
Fast deep equal
path-to-regexp 6.1.0 - 6.2.0Outdated
Express style path to RegExp utility
has-symbols 1.0.2 - 1.0.3
Determine if the JS environment has Symbol support. Supports spec, or shams.
is-buffer 1.1.4 - 1.1.6Outdated
Determine if an object is a Buffer
object-inspect 1.12.2Outdated
string representations of objects in node and the browser
axios 0.26.1Outdated
Promise based HTTP client for the browser and node.js
get-intrinsic 1.1.3Outdated
Get and robustly cache all JS language-level intrinsics at first require time
has 1.0.1 - 1.0.3
Object.prototype.hasOwnProperty.call shortcut
tarruda
ljharb
function-bind 1.1.0 - 1.1.1
Implementation of Function.prototype.bind
call-bind 1.0.2
Robustly `.call.bind()` a function
side-channel 1.0.4
Store information about any JS value in a side channel. Uses WeakMap if available.
prop-types 15.8.0 - 15.8.1
Runtime type checking for React props and similar objects.
scheduler 0.21.0 - 0.23.0
Cooperative scheduler for the browser environment.
react 17.0.0 - 18.2.0
React is a JavaScript library for building user interfaces.
react-dom 18.0.0 - 18.2.0
React package for working with the DOM.
classnames 2.3.2
A simple utility for conditionally joining classNames together
graphql 15.0.0 - 15.8.0Outdated
A Query Language and Runtime which can target any service.
immer 9.0.3 - 9.0.15Outdated
Create your next immutable state by mutating the current one
es6-promise 4.2.4 - 4.2.8
A lightweight library that provides tools for organizing asynchronous code
memoize-one 6.0.0
A memoization library which only remembers the latest invocation
lodash-es 4.17.21
Lodash exported as ES modules.
shallowequal 1.0.1 - 1.1.0
Like lodash isEqualWith but for shallow equal.
charenc 0.0.0 - 0.0.2
character encoding utilities
pvorb
pvorb
js-cookie 3.0.1
A simple, lightweight JavaScript API for handling cookies
resize-observer-polyfill 1.5.0 - 1.5.1
A polyfill for the Resize Observer API
react-select 5.5.5Outdated
A Select control built with and for ReactJS
next 12.3.0 - 12.3.1Outdated
The React Framework
rauchg
timneutkens
vercel-release-bot
rc-util 5.24.4Outdated
Common Utils For React Component
react-draggable 4.4.1 - 4.4.5
React draggable component
@angular/router 10.0.0 - 14.1.3Outdated
Angular - the routing library
rc-trigger 4.3.0 - 4.3.4Outdated
base abstract trigger component for react
json2mq 0.2.0
Generate media query string from JSON or javascript object
akiran
akiran
string-convert 0.2.0 - 0.2.1
String convertions
akiran
akiran
rc-tooltip 5.2.0 - 5.2.2Outdated
React Tooltip
react-dnd-html5-backend 1.0.0 - 16.0.1
HTML5 backend for React DnD
+2
jordangens
gaearon
darthtrevino
@ctrl/tinycolor 3.4.1Outdated
Fast, small color manipulation and conversion for JavaScript
@ant-design/colors 2.0.0 - 6.0.0Outdated
Color palettes calculator of Ant Design
+7
madccc
afc163
vthinkxie
@reach/utils 0.10.4 - 0.11.2Outdated
Internal, shared utilities for Reach UI.
+1
ryanflorence
mjackson
chancestrickland
antd 4.23.0 - 4.23.4Outdated
An enterprise-class UI design language and React components implementation
@ant-design/icons 4.0.0 - 4.7.0Outdated
[![NPM version](https://img.shields.io/npm/v/@ant-design/icons.svg?style=flat)](https://npmjs.org/package/@ant-design/icons) [![NPM downloads](http://img.shields.io/npm/dm/@ant-design/icons.svg?style=flat)](https://npmjs.org/package/@ant-design/icons)
+7
madccc
afc163
vthinkxie
rc-dialog 8.9.0 - 9.0.0Outdated
dialog ui component for react
rc-pagination 3.1.11 - 3.1.17Outdated
pagination ui component for react
rc-notification 4.5.6 - 4.6.0Outdated
notification ui component for react
rc-checkbox 2.3.0 - 2.3.2
checkbox ui component for react
@ant-design/icons-svg 4.1.0 - 4.2.1
Abstract nodes for ant design icons.
+7
madccc
afc163
vthinkxie
rc-picker 2.6.9 - 2.6.11Outdated
React date & time picker
rc-field-form 1.19.0 - 1.27.3
React Form Component
@chakra-ui/theme 2.1.0 - 2.1.3Outdated
The default theme for chakra components
bootstrap-vue 2.0.0 - 2.15.0Outdated
With more than 85 components, over 45 available plugins, several directives, and 1000+ icons, BootstrapVue provides one of the most comprehensive implementations of the Bootstrap v4 component and grid system available for Vue.js v2.6, complete with extens
aos 1.2.0Outdated
Animate on scroll library
michalsnik
michalsnik
react-flip-move 2.6.1 - 2.6.2Outdated
Effortless animation between DOM changes (eg. list reordering) using the FLIP technique.
tesseract.js 2.0.0 - 3.0.3Outdated
Pure Javascript Multilingual OCR
+1
antimatter15
jeromewu
bijection
react-bootstrap-sweetalert 2.0.0 - 5.2.0
A variant of sweetalert for use with React and Bootstrap
botframework-webchat-component 4.1.0 - 4.7.1Outdated
React component of botframework-webchat
+2
botframework
joshgummersall
sgellock
react-amphtml 3.1.0 - 4.0.2
Use amphtml components inside your React apps easily!
dfrankland
dfrankland