www.pizzahut.co.uk 135 packages

Last scanned onΒ Oct 27 at 07:57 PM
lodash 4.17.16VulnerableOutdated
Lodash modular utilities.
License
MIT
Footprint
11 KB
Vulnerabilities
Prototype Pollution in lodash
Affected versions >=0 <4.17.20
Command Injection in lodash
Affected versions >=0 <4.17.21
Regular Expression Denial of Service (ReDoS) in lodash
Affected versions >=0 <4.17.21
Matched Modules
Version distribution in production
3 846
4.17.16
946
4.17.21
337
4.17.20
322
4.17.15
302
4.17.19
301
4.17.13
next 6.0.0 - 7.0.3VulnerableOutdated
The React Framework
rauchg
timneutkens
vercel-release-bot
sweetalert2 11.4.9 - 11.4.18VulnerableOutdated
A beautiful, responsive, customizable and accessible (WAI-ARIA) replacement for JavaScript's popup boxes, supported fork of sweetalert
tslib 1.9.2 - 2.4.0Outdated
Runtime library for TypeScript helper functions
readable-stream 2.3.4 - 2.3.7Outdated
Node.js Streams, a user-land copy of the stream library from Node.js
string_decoder 1.1.0 - 1.3.0
The string_decoder module from Node core
uuid 7.0.0 - 8.0.0Outdated
RFC4122 (v1, v4, and v5) UUIDs
isarray 0.0.0 - 2.0.5
Array#isArray for older browsers
react-is 16.3.0 - 16.13.1Outdated
Brand checking of React Elements.
inherits 2.0.3 - 2.0.4
Browser-friendly inheritance fully compatible with standard node.js inherits()
buffer 4.6.0 - 4.9.2Outdated
Node.js Buffer API, for the browser
@babel/runtime 7.13.6 - 7.13.7Outdated
babel's modular runtime helpers
+1
hzoo
existentialism
nicolo-ribaudo
path-to-regexp 1.7.0 - 1.8.0Outdated
Express style path to RegExp utility
cookie 0.2.4 - 0.4.2Outdated
HTTP server cookie parsing and serialization
dougwilson
dougwilson
core-util-is 1.0.2 - 1.0.3
The `util.is*` functions introduced in Node v0.12.
base64-js 1.3.0 - 1.5.1
Base64 encoding/decoding in pure JS
core-js 3.18.2 - 3.18.3Outdated
Standard library
@typescript-eslint/scope-manager 3.7.0 - 5.41.0Outdated
TypeScript scope analyser for ESLint
events 3.0.0 - 3.3.0
Node's event emitter for all engines.
util 0.10.0 - 0.12.5
Node.js's util module for all engines
pako 1.0.6 - 1.0.11Outdated
zlib port to javascript - fast, modularized, with browser support
json-stringify-safe 5.0.1
Like JSON.stringify, but doesn't blow up on circular refs.
prop-types 15.7.0 - 15.7.2Outdated
Runtime type checking for React props and similar objects.
scheduler 0.15.0 - 0.23.0
Cooperative scheduler for the browser environment.
react 16.13.0 - 17.0.2Outdated
React is a JavaScript library for building user interfaces.
url 0.11.0Outdated
The core `url` packaged standalone for use with Browserify.
lodash.debounce 4.0.8
The lodash method `_.debounce` exported as a module.
react-dom 16.13.0 - 16.14.0Outdated
React package for working with the DOM.
hoist-non-react-statics 3.3.1 - 3.3.2
Copies non-react specific statics from a child component to a parent component
mridgway
mridgway
@emotion/unitless 0.7.2 - 0.8.0Outdated
An object of css properties that don't accept values with units
+1
emmatown
tkh44
emotion-release-bot
@hapi/hoek 8.5.1Outdated
General purpose node utilities
@aws-crypto/sha256-js 1.2.0 - 2.0.2Outdated
A pure JS implementation SHA256.
+5
amzn-oss
seebees
agray256
react-transition-group 2.3.0 - 2.5.2Outdated
A react component toolset for managing animations
assert 1.0.0 - 1.5.0Outdated
The assert module from Node.js, for the browser.
dom-helpers 5.0.1 - 5.2.1
tiny modular DOM lib for ie9+
@aws-crypto/util 1.2.0Outdated
Helper functions
+5
amzn-oss
seebees
agray256
classnames 2.3.0 - 2.3.1Outdated
A simple utility for conditionally joining classNames together
whatwg-fetch 3.4.0 - 3.6.2Outdated
A window.fetch polyfill.
jakechampion
mattandrews
mislav
browserify-zlib 0.2.0
Full zlib module for the browser
@aws-sdk/util-utf8-browser 3.0.0 - 3.188.0Outdated
A browser UTF-8 string <-> UInt8Array converter
+2
mattsb42-aws
kuhe
amzn-oss
@aws-crypto/supports-web-crypto 0.1.0 - 2.0.2Outdated
Provides functions for detecting if the host environment supports the WebCrypto API
+5
amzn-oss
seebees
agray256
@aws-crypto/ie11-detection 0.1.0 - 2.0.2Outdated
Provides functions and types for detecting if the host environment is IE11
+5
amzn-oss
seebees
agray256
@aws-crypto/sha256-browser 1.2.0 - 2.0.2Outdated
SHA256 wrapper for browsers that prefers `window.crypto.subtle` but will fall back to a pure JS implementation in @aws-crypto/sha256-js to provide a consistent interface for SHA256.
+5
amzn-oss
seebees
agray256
graphql 15.4.0 - 15.8.0Outdated
A Query Language and Runtime which can target any service.
@hapi/topo 3.1.4 - 5.0.0Outdated
Topological sorting with grouping support
es5-ext 0.10.24 - 0.10.49Outdated
ECMAScript extensions and shims
react-router 6.0.0 - 6.3.0Outdated
Declarative routing for React
react-fast-compare 3.1.0 - 3.2.0Outdated
Fastest deep equal comparison for React. Great for React.memo & shouldComponentUpdate. Also really fast general-purpose deep comparison.
react-router-dom 6.0.0 - 6.3.0Outdated
Declarative routing for React web applications
timers-browserify 2.0.9Outdated
timers module for browserify
crypto-browserify 1.0.9 - 2.0.0Outdated
implementation of crypto for the browser
+2
dcousens
ljharb
cwmma
gaxios 2.0.1Outdated
A simple common HTTP client specifically for Google APIs and services.
google-wombot
google-wombot
tiny-invariant 0.0.2 - 1.3.1
A tiny invariant function
@sentry/utils 5.21.0 - 6.5.1Outdated
Utilities for all Sentry JavaScript SDKs
+9
benvinegar
billyvg
mitsuhiko
querystring-es3 0.2.1
Node's querystring module for all engines. (ES3 compat fork)
redux 4.0.1Outdated
Predictable state container for JavaScript apps
@aws-sdk/protocol-http 3.0.0 - 3.12.0Outdated
[![NPM version](https://img.shields.io/npm/v/@aws-sdk/protocol-http/latest.svg)](https://www.npmjs.com/package/@aws-sdk/protocol-http) [![NPM downloads](https://img.shields.io/npm/dm/@aws-sdk/protocol-http.svg)](https://www.npmjs.com/package/@aws-sdk/prot
+2
amzn-oss
aws-sdk-bot
kuhe
@aws-sdk/property-provider 3.0.0 - 3.6.1Outdated
[![NPM version](https://img.shields.io/npm/v/@aws-sdk/property-provider/latest.svg)](https://www.npmjs.com/package/@aws-sdk/property-provider) [![NPM downloads](https://img.shields.io/npm/dm/@aws-sdk/property-provider.svg)](https://www.npmjs.com/package/@
+2
amzn-oss
aws-sdk-bot
kuhe
@sentry/core 5.10.2 - 6.16.1Outdated
Base implementation for all Sentry JavaScript SDKs
+9
benvinegar
billyvg
mitsuhiko
history 4.0.0 - 5.3.0
Manage session history with JavaScript
lodash-es 4.17.21
Lodash exported as ES modules.
traverse 0.6.1 - 0.6.7
traverse and transform objects by visiting every node on a recursive walk
shallowequal 1.0.1 - 1.1.0
Like lodash isEqualWith but for shallow equal.
@aws-sdk/smithy-client 3.0.0 - 3.197.0Outdated
[![NPM version](https://img.shields.io/npm/v/@aws-sdk/smithy-client/latest.svg)](https://www.npmjs.com/package/@aws-sdk/smithy-client) [![NPM downloads](https://img.shields.io/npm/dm/@aws-sdk/smithy-client.svg)](https://www.npmjs.com/package/@aws-sdk/smit
+2
amzn-oss
aws-sdk-bot
kuhe
react-lifecycles-compat 3.0.4
Backwards compatibility polyfill for React class components
fb
sophiebits
@aws-sdk/middleware-serde 3.4.0 - 3.197.0Outdated
[![NPM version](https://img.shields.io/npm/v/@aws-sdk/middleware-serde/latest.svg)](https://www.npmjs.com/package/@aws-sdk/middleware-serde) [![NPM downloads](https://img.shields.io/npm/dm/@aws-sdk/middleware-serde.svg)](https://www.npmjs.com/package/@aws
+2
amzn-oss
aws-sdk-bot
kuhe
reselect 4.1.0 - 4.1.6Outdated
Selectors for Redux.
@emotion/stylis 0.8.1 - 0.8.5
A custom build of Stylis
+1
emmatown
tkh44
emotion-release-bot
luxon 0.2.1 - 1.28.0Outdated
Immutable date wrapper
unfetch 4.1.0 - 4.2.0Outdated
Bare minimum fetch polyfill in 500 bytes
graphql-tag 2.12.2 - 2.12.6
A JavaScript template literal tag that parses GraphQL queries
jnwng
abernix
apollo-bot
styled-components 5.2.0 - 5.3.6Outdated
CSS for the <Component> Age. Style components your way with speed, strong typing, and flexibility.
crypto-js 4.1.0 - 4.1.1
JavaScript library of crypto standards.
p-is-promise 3.0.0 - 4.0.0
Check if something is a promise
zen-observable-ts 1.1.0 - 1.2.3
Thin wrapper around zen-observable and @types/zen-observable, to support ESM exports as well as CommonJS exports
jbaxleyiii
apollo-bot
expand-template 1.0.0 - 1.0.4Outdated
Expand placeholders in a template string
es6-promisify 6.0.1 - 7.0.0
Converts callback-based functions to ES6 Promises
ts-invariant 0.3.0 - 0.10.3
TypeScript implementation of invariant(condition, message)
@hapi/bourne 1.2.0 - 3.0.0
JSON parse with prototype poisoning protection
@wry/equality 0.5.1 - 0.5.2Outdated
Structural equality checking for JavaScript values
benjamn
benjamn
@sentry/hub 4.3.3 - 6.19.4Outdated
Sentry hub which handles global state managment.
+9
benvinegar
billyvg
mitsuhiko
is-color-stop 1.0.0 - 1.1.0
Check if a string is CSS color stop
@wry/context 0.4.0 - 0.6.1Outdated
Manage contextual information needed by (a)synchronous tasks without explicitly passing objects around
benjamn
benjamn
@aws-sdk/client-cognito-identity 3.1.0 - 3.131.0Outdated
AWS SDK for JavaScript Cognito Identity Client for Node.js, Browser and React Native
+2
mattsb42-aws
kuhe
amzn-oss
mini-create-react-context 0.3.3 - 0.4.1
Smaller Polyfill for the proposed React context API
@aws-sdk/credential-provider-cognito-identity 3.0.0 - 3.186.0Outdated
[![NPM version](https://img.shields.io/npm/v/@aws-sdk/credential-provider-cognito-identity/latest.svg)](https://www.npmjs.com/package/@aws-sdk/credential-provider-cognito-identity) [![NPM downloads](https://img.shields.io/npm/dm/@aws-sdk/credential-provid
+2
mattsb42-aws
kuhe
amzn-oss
intl-messageformat 2.1.0 - 2.2.0Outdated
Formats ICU Message strings with number, date, plural, and select placeholders to create localized messages.
optimism 0.16.1Outdated
Composable reactive caching with efficient invalidation.
web-vitals 0.2.1 - 0.2.2Outdated
Easily measure performance metrics in JavaScript
@sentry/minimal 4.3.3 - 6.19.7
Sentry minimal library that can be used in other packages
+9
benvinegar
billyvg
mitsuhiko
@wry/trie 0.2.1 - 0.3.2Outdated
https://en.wikipedia.org/wiki/Trie
@apollo/client 3.5.8 - 3.6.4Outdated
A fully-featured caching GraphQL client.
exenv 1.1.0 - 1.2.2
React's ExecutionEnvironment module extracted for use in other packages & components
is-in-browser 2.0.0
Simple check to see if current app is running in browser
tuxsudo
tuxsudo
react-side-effect 2.1.0 - 2.1.2
Create components whose prop changes map to a global side effect
@datadog/browser-core 1.2.2 - 4.23.2Outdated
Datadog browser core utilities.
datadog
datadog
react-modal 3.14.1 - 3.16.1
Accessible modal dialog component for React.JS
intl-messageformat-parser 1.3.0 - 1.5.1Outdated
Parses ICU Message strings into an AST via JavaScript.
universal-cookie 4.0.1 - 4.0.4Outdated
Universal cookies for JavaScript
@fortawesome/free-solid-svg-icons 5.1.0 - 5.15.4Outdated
The iconic font, CSS, and SVG framework
react-intl 2.1.5 - 2.9.0Outdated
Internationalize React apps. This library provides React components and an API to format dates, numbers, and strings, including pluralization and handling translations.
xstate 4.7.0 - 4.33.6Outdated
Finite State Machines and Statecharts for the Modern Web.
shortid 2.2.15 - 2.2.16
Amazingly short non-sequential url-friendly unique id generator.
rc-select 8.6.7 - 8.6.8Outdated
React Select
redux-saga 0.15.1 - 0.16.2Outdated
Saga middleware for Redux to handle Side Effects
amazon-cognito-identity-js 4.2.0 - 5.2.12Outdated
Amazon Cognito Identity Provider JavaScript SDK
@fortawesome/react-fontawesome 0.1.5 - 0.1.8Outdated
Official React component for Font Awesome 5
+4
jasonlundien
devoto13
jrjohnson
redux-persist 4.0.0 - 4.7.1Outdated
persist and rehydrate redux stores
andarist
rt2zz
@redux-saga/core 1.0.0 - 1.2.1Outdated
Saga middleware for Redux to handle Side Effects
@redux-saga/symbols 1.0.0 - 1.1.3
Redux-saga internal symbol "registry".
@redux-saga/is 1.0.0 - 1.1.3
Runtime type checking helpers
yelouafi
andarist
redux-saga-release-bot
@redux-saga/delay-p 1.0.0 - 1.1.2Outdated
Promisified setTimeout
@aws-amplify/core 4.4.0 - 4.7.10Outdated
Core category of aws-amplify
+7
aws-amplify-docs-eng-ops
amplify-data-dev-npm
amplify-studio-uibuilder
@aws-amplify/auth 4.4.3 - 4.5.10Outdated
Auth category of aws-amplify
+7
aws-amplify-docs-eng-ops
amplify-data-dev-npm
amplify-studio-uibuilder
style-inject 0.3.0
Inject style tag to document head.
styled-system 3.1.0 - 3.1.2Outdated
Responsive, theme-based style props for building design systems with React
murmurhash 0.0.1 - 0.0.2Outdated
A Node.js module for the optimized JavaScript implementation of the MurmurHash algorithms.
perezd
perezd
connected-react-router 6.1.0 - 6.9.3
A Redux binding for React Router v4 and v5
supasate
supasate
final-form 4.18.7Outdated
🏁 Framework agnostic, high performance, subscription-based form state management
erikras
erikras
redux-form 7.0.2 - 8.3.8Outdated
A higher order component decorator for forms using Redux and React
react-final-form 6.3.4 - 6.5.9
🏁 High performance subscription-based form state management for React
erikras
erikras
@optimizely/js-sdk-utils 0.1.0 - 0.4.0
Optimizely Full Stack Utils
optimizely-fullstack
optimizely-fullstack
@optimizely/optimizely-sdk 4.6.1 - 4.9.2Outdated
JavaScript SDK for Optimizely Feature Experimentation, Optimizely Full Stack (legacy), and Optimizely Rollouts
optimizely-fullstack
optimizely-fullstack
@optimizely/js-sdk-logging 0.1.0 - 0.3.1
Optimizely Full Stack Core Logging
optimizely-fullstack
optimizely-fullstack
@optimizely/js-sdk-event-processor 0.5.0 - 0.9.5
Optimizely Full Stack Event Processor
optimizely-fullstack
optimizely-fullstack
@optimizely/js-sdk-datafile-manager 0.2.0 - 0.9.5
Optimizely Full Stack Datafile Manager
optimizely-fullstack
optimizely-fullstack
intl-relativeformat 2.2.0Outdated
Formats JavaScript dates to relative time strings.
react-places-autocomplete 7.3.0
A React component for Google Maps Places Autocomplete
react-instantsearch-dom 6.13.0 - 6.38.0Outdated
⚑ Lightning-fast search for React DOM, by Algolia
react-countdown 2.2.0 - 2.3.3Outdated
A customizable countdown component for React.
apollo-link-retry 2.2.12 - 2.2.16
Retry Apollo Link for GraphQL Network Stack
nevir
jbaxleyiii
apollo-bot
@optimizely/react-sdk 2.4.0 - 2.9.1Outdated
React SDK for Optimizely Feature Experimentation, Optimizely Full Stack (legacy), and Optimizely Rollouts
optimizely-fullstack
optimizely-fullstack
@tannin/plural-forms 1.0.0 - 1.1.0
Compiles a function to compute the plural forms index for a given value
aduth
aduth
lottie-api 1.0.0 - 1.0.2Outdated
A library to edit lottie-web animations dynamically
airnan
airnan
web-speech-cognitive-services 7.1.1Outdated
Polyfill Web Speech API with Cognitive Services Speech-to-Text service