zooniverse.org 95 packages

Last scanned on Oct 27 at 06:47 PM
lodash 4.17.16VulnerableOutdated
Lodash modular utilities.
License
MIT
Footprint
5 KB
Vulnerabilities
Command Injection in lodash
Affected versions >=0 <4.17.21
Regular Expression Denial of Service (ReDoS) in lodash
Affected versions >=0 <4.17.21
Prototype Pollution in lodash
Affected versions >=3.7.0 <4.17.19
Matched Modules
Version distribution in production
3 846
4.17.16
946
4.17.21
337
4.17.20
322
4.17.15
302
4.17.19
301
4.17.13
es5-ext 0.10.24 - 0.10.49VulnerableOutdated
ECMAScript extensions and shims
isarray 1.0.0 - 2.0.5
Array#isArray for older browsers
react-is 16.3.0 - 18.2.0
Brand checking of React Elements.
inherits 2.0.3 - 2.0.4
Browser-friendly inheritance fully compatible with standard node.js inherits()
qs 6.6.1 - 6.11.0Outdated
A querystring parser that supports nesting and arrays, with a depth limit
buffer 4.6.0 - 4.9.2Outdated
Node.js Buffer API, for the browser
get-intrinsic 1.1.0 - 1.1.1Outdated
Get and robustly cache all JS language-level intrinsics at first require time
function-bind 1.1.0 - 1.1.1Outdated
Implementation of Function.prototype.bind
object-inspect 1.11.0 - 1.11.1Outdated
string representations of objects in node and the browser
call-bind 1.0.2Outdated
Robustly `.call.bind()` a function
has-symbols 1.0.2 - 1.0.3
Determine if the JS environment has Symbol support. Supports spec, or shams.
sprintf-js 1.1.2Outdated
JavaScript sprintf implementation
alexei
alexei
side-channel 1.0.4Outdated
Store information about any JS value in a side channel. Uses WeakMap if available.
base64-js 1.3.0 - 1.5.1
Base64 encoding/decoding in pure JS
events 3.0.0 - 3.3.0
Node's event emitter for all engines.
core-js 2.6.12Outdated
Standard library
util 0.10.0 - 0.12.5
Node.js's util module for all engines
has 1.0.1 - 1.0.3Outdated
Object.prototype.hasOwnProperty.call shortcut
tarruda
tarruda
extend 3.0.2
Port of jQuery.extend for node.js and the browser
scheduler 0.15.0 - 0.23.0
Cooperative scheduler for the browser environment.
prop-types 15.7.0 - 15.7.2Outdated
Runtime type checking for React props and similar objects.
react 17.0.0 - 18.2.0
React is a JavaScript library for building user interfaces.
lodash.debounce 4.0.8
The lodash method `_.debounce` exported as a module.
url 0.11.0Outdated
The core `url` packaged standalone for use with Browserify.
minimalistic-assert 1.0.0 - 1.0.1
minimalistic-assert ===
cwmma
indutny
hoist-non-react-statics 3.3.1 - 3.3.2
Copies non-react specific statics from a child component to a parent component
mridgway
mridgway
@emotion/unitless 0.7.2 - 0.8.0Outdated
An object of css properties that don't accept values with units
+1
emmatown
tkh44
emotion-release-bot
path-browserify 0.0.0 - 0.0.1Outdated
the path module from node core for browsers
classnames 2.2.6Outdated
A simple utility for conditionally joining classNames together
fast-safe-stringify 2.1.1
Safely and quickly serialize JavaScript objects
dom-helpers 5.1.4 - 5.2.1
tiny modular DOM lib for ie9+
stylis 3.1.0 - 3.5.4Outdated
A Light–weight CSS Preprocessor
andarist
thysultan
query-string 2.3.0 - 5.0.1Outdated
Parse and stringify URL query strings
memoize-one 4.0.2 - 4.0.3Outdated
A memoization library which only remembers the latest invocation
hash.js 1.1.2 - 1.1.7
Various hash functions that could be run by both browser and node
@sentry/utils 5.21.0 - 6.5.1Outdated
Utilities for all Sentry JavaScript SDKs
+8
benvinegar
billyvg
mitsuhiko
react-router 3.0.4 - 3.2.6Outdated
Declarative routing for React
@sentry/core 5.10.2 - 6.16.1Outdated
Base implementation for all Sentry JavaScript SDKs
+8
benvinegar
billyvg
mitsuhiko
react-fast-compare 2.0.4Outdated
Fastest deep equal comparison for React. Great for React.memo & shouldComponentUpdate. Also really fast general-purpose deep comparison.
sourcemap-codec 1.0.0 - 1.3.1Outdated
Encode/decode sourcemap mappings
rich_harris
rich_harris
redux 4.0.1 - 4.2.0Outdated
Predictable state container for JavaScript apps
lodash-es 4.17.21
Lodash exported as ES modules.
superagent 3.8.0 - 8.0.3Outdated
elegant & feature rich browser / node HTTP with a fluent API
querystring-es3 0.2.1
Node's querystring module for all engines. (ES3 compat fork)
mdurl 1.0.0 - 1.0.1Outdated
URL utilities for markdown-it
vitaly
vitaly
shallowequal 1.0.1 - 1.1.0
Like lodash isEqualWith but for shallow equal.
babel-runtime 6.18.0 - 6.26.0
babel selfContained runtime
hzoo
loganfsmyth
existentialism
react-redux 5.0.3 - 8.0.4Outdated
Official React bindings for Redux
linkify-it 3.0.3Outdated
Links recognition library with FULL unicode support
polished 1.0.0 - 4.2.2Outdated
A lightweight toolset for writing styles in Javascript.
uc.micro 1.0.6Outdated
Micro subset of unicode data files for markdown-it projects.
vitaly
vitaly
markdown-it 12.3.2Outdated
Markdown-it - modern pluggable markdown parser.
styled-components 4.0.0 - 4.2.1Outdated
CSS for the <Component> Age. Style components your way with speed, strong typing, and flexibility.
react-select 1.0.0 - 3.0.1Outdated
A Select control built with and for ReactJS
p-is-promise 3.0.0 - 4.0.0
Check if something is a promise
debounce 1.2.0 - 1.2.1Outdated
Delay function calls until a set time elapses after the last invocation
@sentry/browser 5.27.0 - 6.16.1Outdated
Official Sentry SDK for browsers
+8
benvinegar
billyvg
mitsuhiko
redux-thunk 2.1.0 - 2.4.1Outdated
Thunk middleware for Redux.
lodash.throttle 4.1.1
The lodash method `_.throttle` exported as a module.
intl-messageformat 1.0.2 - 3.0.0Outdated
Formats ICU Message strings with number, date, plural, and select placeholders to create localized messages.
@sentry/hub 5.21.0 - 6.19.4Outdated
Sentry hub which handles global state managment.
+8
benvinegar
billyvg
mitsuhiko
rc-util 4.20.3 - 5.3.0Outdated
Common Utils For React Component
@apollo/client 3.0.0 - 3.7.1Outdated
A fully-featured caching GraphQL client.
@sentry/minimal 4.3.3 - 6.19.7
Sentry minimal library that can be used in other packages
+8
benvinegar
billyvg
mitsuhiko
@sentry/tracing 5.28.0 - 6.19.7Outdated
Sentry Performance Monitoring Package
+8
benvinegar
billyvg
mitsuhiko
react-input-autosize 2.2.2Outdated
Auto-resizing Input Component for React
react-side-effect 1.2.0Outdated
Create components whose prop changes map to a global side effect
react-helmet 5.2.0 - 5.2.1Outdated
A document head manager for React
react-beautiful-dnd 1.0.0 - 6.0.2Outdated
Beautiful and accessible drag and drop for lists with React
lit-element 3.0.0Outdated
A simple base class for creating fast, lightweight web components
+11
aomarks
emarquez
sorvell
xstate 4.7.0 - 4.33.6Outdated
Finite State Machines and Statecharts for the Modern Web.
create-react-class 15.7.0
Legacy API for creating React components.
element-resize-detector 1.2.1 - 1.2.3Outdated
Resize event emitter for elements.
wnr
wnr
batch-processor 1.0.0
Batch processing in JS
wnr
wnr
react-sizeme 2.4.0 - 2.6.6Outdated
Make your React Components aware of their width and/or height!
ctrlplusb
ctrlplusb
antd 4.1.0 - 4.2.4Outdated
An enterprise-class UI design language and React components implementation
react-chartjs-2 2.10.0 - 2.11.2Outdated
React components for Chart.js
rc-select 7.3.2 - 8.2.9Outdated
React Select
react-slick 0.27.11 - 0.28.1Outdated
React port of slick carousel
stylis-rule-sheet 0.0.9 - 0.0.10
stylis plugin to extract individual rules to use with insertRule API
thysultan
thysultan
striptags 3.2.0
PHP strip_tags in Node.js
react-phone-number-input 1.0.1 - 1.1.14Outdated
Telephone number input React component
component-indexof 0.0.3
Microsoft sucks
component-classes 1.2.5Outdated
Cross-browser element class list
next-i18next 1.0.0 - 7.0.1Outdated
The easiest way to translate your NextJs apps.
bootstrap-vue 1.0.0 - 2.15.0Outdated
With more than 85 components, over 45 available plugins, several directives, and 1000+ icons, BootstrapVue provides one of the most comprehensive implementations of the Bootstrap v4 component and grid system available for Vue.js v2.6, complete with extens
i18n-js 4.0.1 - 4.1.1Outdated
A small library to provide I18n on JavaScript.
fnando
fnando
instantsearch.js 3.1.0 - 3.7.0Outdated
InstantSearch.js is a JavaScript library for building performant and instant search experiences with Algolia.
semantic-ui-react 0.86.0 - 1.1.0Outdated
The official Semantic-UI-React integration.
layershifter
levithomason
chartist 0.11.4Outdated
Simple, responsive charts
@optimizely/react-sdk 2.0.0 - 2.9.1Outdated
React SDK for Optimizely Feature Experimentation, Optimizely Full Stack (legacy), and Optimizely Rollouts
optimizely-fullstack
optimizely-fullstack
scroll-behavior 0.9.7 - 0.11.0
Pluggable browser scroll management
taion
taion
reactour 1.7.2 - 1.8.5Outdated
Tourist Guide into your React Components
botframework-webchat-component 4.14.1 - 4.15.3Outdated
React component of botframework-webchat
+2
botframework
sgellock
cwhitten